Contact Us
If you need help, we'd love to hear from you.
Please read the support page for your product before writing to us.
If you are unable to use this form, or need to send an attachment, please e-mail to:

FEB 17, 2019 - EARTHDESK
EarthDesk 6.8 is the minimum version required for cloud images. Earlier versions may display a milky white film over the entire map. If you experience the milky white display, and wish to update to 6.8, you should uninstall your earlier version of EarthDesk before updating to version 6.8.

Enter the six characters shown below.